Pixelated a phpBB Template by SkaidonDesigns
 
Kaktusan Corp. Support Area Forum Index
www.kaktusancorp.com
www.cheapestadultscripts.com
Play with the Best, be the Best!
Special Offer
FAQ
Search
Memberlist
Usergroups
Profile
Log in to check your private messages
Log in

The Mightiest Webmaster Solutions Ever
Blogs Organizer
Blogs Organizer
Blogs Automater
Blogs Automater
Porn Blog Space
Porn Blog Space
Links Organizer
Links Organizer

Haven't registered yet? Do it here now!
Problem with 777 error when setting up

 
Post new topic   Reply to topic    Kaktusan Corp. Support Area Forum Index -> Site Organizer
View previous topic :: View next topic  
Author Message
Xcaliber



Joined: 02 Jan 2009
Posts: 7

PostPosted: Fri Jan 02, 2009 7:00 pm    Post subject: Problem with 777 error when setting up Reply with quote
Hello, I trying to set up the script but seem to be having problems. I uploaded it with cute ftp pro with no problems. when i run the so-install.php to set it up it gives me a 777 error message. The info is below. Any ideas on how to fix this would be greatly appreciated Aaron

Hosting company is the recommended protgp from your site
Initial Checks:
PHP Version: 4.4.7 OK
PHP Safe Mode: OK
MySQL Support: OK
CURL Library Support: OK
Image Magick Support: No Image Magick! (its okay if you have PHP GD Library)
PHP GD Library Support: OK
"soinfo.inc.php" File: Incorrect file permissions! Must be 777
"sohtml" Directory: Incorrect "sohtml" directory permissions! Must be 777
"thumbs" Directory: Incorrect "thumbs" directory permissions! Must be 777
"sotemp" Directory: Incorrect "sotemp" directory permissions! Must be 777
The following errors occured:
Incorrect soinfo.inc.php permissions! Must be 777!
Back to top
View user's profile Send private message

Author Message
Xcaliber



Joined: 02 Jan 2009
Posts: 7

PostPosted: Sat Jan 03, 2009 6:47 pm    Post subject: Reply with quote
OkI email protgp support and received a answer about the error and it is as follows


Support-If your script requires permissions to be 777 then you should replace it with something better.

Your account is in the group of all customer accounts. That means that all permissions should be ZERO in the middle because there is NO REASON to give other customers ANY access to your files. It is insane and/or grossly irresponsible for some script author to say that you should give other customers write access to your files or scripts.

I think the 777 permission is senses it is the free version and 3% skim correct.Well that what i told them anyway. I would like to try this out before I purchase it, so you may need to recommend a new hosting company that will work with me. Thanks Aaron
Back to top
View user's profile Send private message

Author Message
kaktus
Owner


Joined: 22 May 2004
Posts: 1576
Location: CheapestAdultScripts.com

PostPosted: Mon Jan 05, 2009 6:29 pm    Post subject: Reply with quote
hi there,
yeah ProTGP are kinda picky sometimes.

Don't chmod to 777. Try 666 or 644
My scripts check for read/write permissions, so any permissions that will let the script write to a file will be fine.

I and 99% of the software producers say we need 777, because hosting companies regularly put the apache user separate from your own user and when you upload with your user, apache can't write to the files. Thats why 777 is needed.
_________________
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number

Author Message
Xcaliber



Joined: 02 Jan 2009
Posts: 7

PostPosted: Mon Jan 05, 2009 6:34 pm    Post subject: Reply with quote
hello your going to need to explain step buy step what i need to do. Im new to the scripts.php and css thing. Im old school frontpage dream weaver user thanks aaron
Back to top
View user's profile Send private message

Author Message
kaktus
Owner


Joined: 22 May 2004
Posts: 1576
Location: CheapestAdultScripts.com

PostPosted: Mon Jan 05, 2009 7:01 pm    Post subject: Reply with quote
go with your ftp client to the SO directory as you uploaded on your server. And change the permissions of those files and directories to 666. Find the option somewhere in your ftp client, probably right clicking over the file or directory..
_________________
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number

Author Message
Xcaliber



Joined: 02 Jan 2009
Posts: 7

PostPosted: Tue Jan 06, 2009 2:45 am    Post subject: Reply with quote
Ok i change them to 666 and it installed.but when i login it is a blank page.
I tried reinstalling it but that didnt work. anymore ideas

my url-hxxtp://www.cloud9sexlinks.com/
Back to top
View user's profile Send private message

Author Message
kaktus
Owner


Joined: 22 May 2004
Posts: 1576
Location: CheapestAdultScripts.com

PostPosted: Tue Jan 06, 2009 4:25 pm    Post subject: Reply with quote
mm, best and easier for us would be if you pm me ftp access and mysql info and i install the script for you
_________________
Back to top
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number

Author Message
Xcaliber



Joined: 02 Jan 2009
Posts: 7

PostPosted: Wed Jan 07, 2009 1:30 am    Post subject: Reply with quote
Hello, I received email from protgp support. And they said this script needs to be run using there php-as-cgi option. They fix it everything seems to be working. Thanks for the offer to fix it Aaron
Back to top
View user's profile Send private message

Author Message
Xcaliber



Joined: 02 Jan 2009
Posts: 7

PostPosted: Thu Jan 08, 2009 3:33 am    Post subject: Reply with quote
Ok please disregard the hosting and sql info sent threw private pm.
I'm still having problems even after hosting company made changes. So for now I have drop them and will find something better less headache. Aaron
Back to top
View user's profile Send private message

Author Message
Xcaliber



Joined: 02 Jan 2009
Posts: 7

PostPosted: Thu Jan 08, 2009 4:49 am    Post subject: Reply with quote
I found the problem. With cute ftp pro 8 transfer is set to use global settings by default. Once changed to the recommended binary and files re uploaded
the back end now works. I'm final good to go. Aaron
Back to top
View user's profile Send private message

Display posts from previous:   
Post new topic   Reply to topic    Kaktusan Corp. Support Area Forum Index -> Site Organizer All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group


 
phpBB Template designed by SkaidonDesigns